1045 Favorite Color Stripe (30 point(s))

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

经验总结:

这一题是DP问题,可以用LCS以及LIS解决,只不过用LCS解决时,需要修改状态方程。用LIS时,需要利用映射方法,将所给的喜爱颜色序列按顺序进行编号,就可以将问题转换为经典的LIS问题啦。

AC代码

LCS:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[210][10010],a[210],b[10010];

int main()
{
	int n,m,t,L;
	scanf("%d %d",&n,&m);
	for(int i=1;i<=m;++i)
	{
		scanf("%d",&a[i]);
		dp[i][0]=0;
	}
	scanf("%d",&L);
	for(int i=1;i<=L;++i)
	{
		scanf("%d",&b[i]);
		dp[0][i]=0;
	}
	dp[0][0]=0;
	for(int i=1;i<=m;++i)
	{
		for(int j=1;j<=L;++j)
		{
			if(a[i]==b[j])
				dp[i][j]=max(dp[i-1][j],dp[i][j-1])+1;
			else
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
		}
	}
	printf("%d\n",dp[m][L]);
	return 0;
}

LIS

#include <cstdio>
#include <cstring>
int hash[210],dp[10010],stripe[10010],order[210];

int main()
{
	int n,m,t,L;
	scanf("%d %d",&n,&m);
	memset(hash,-1,sizeof(hash));
	for(int i=0;i<m;++i)
	{
		scanf("%d",&t);
		hash[t]=i;
	}
	scanf("%d",&L);
	int num=0;
	for(int i=0;i<L;++i)
	{
		scanf("%d",&t);
		if(hash[t]!=-1)
			stripe[num++]=hash[t];
	}
	int ans=-1;
	for(int i=0;i<num;++i)
	{
		dp[i]=1;
		for(int j=0;j<i;++j)
			if(stripe[j]<=stripe[i]&&dp[i]<dp[j]+1)
				dp[i]=dp[j]+1;
		ans=ans>dp[i]?ans:dp[i];
	}
	printf("%d\n",ans);
	return 0;
}

 

 

更多推荐

PAT 甲级 1045  Favorite Color Stripe