Jessica’s Reading Problem

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22716 Accepted: 7687

Description

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

题目意思就是要读最少的连续书页,复习到所有的知识点。
这道题目跟 poj3061 有点像,但是比之稍复杂。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<map>
using namespace std;
const int N = 1e6 + 10;
map<int, int> m, Count;//第一个m是记录书的总页数。第二个是用来后面计数的
int a[N], n, ans, sum;
int solve() {
	int now = 0,l = 1, r = 1;
	while(true) {
		while(now < sum && r <= n) {//条件满足或者后面没有元素了
			if(Count[a[r++]]++ == 0)//这是第一次加入这本书。
				now++;
		}
			if(now < sum)
				break;
			ans = min(ans, r - l);//取答案的最下值。
			if(--Count[a[l++]] == 0)//这是里面的最后一本书。
				now--;
	}
	return ans;
}
int main() {
	while(scanf("%d", &n) != EOF) {
		m.clear();//队组读入注意清零。
		Count.clear();
		ans = N, sum = 0;
		for(int i = 1; i <= n; i++) {
			scanf("%d", &a[i]);
			if(m[a[i]]++ == 0)
				sum++;
		}
		printf("%d\n", solve());
	}
	return 0;
}

更多推荐

POJ3320 Jessica's Reading Problem 尺取法