scanf比cin的效率高出一倍还要多

上面A的两次除了数据读取不一样其余完全相同!!!

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1
Sample Output
2

题意:一本书总共有P页,第i页恰好有知识点ai,全书中一个知识点可能会多次提到
找一个页码范围,把所有知识点都涵盖。输出最小页数
和前面那个Subsequence一样,尺取法。
所有知识点都覆盖既每个知识点出现的次数都不小于1

#include<iostream>
#include<string>
#include<set>
#include<map>
using namespace std;
#define MAX 1000000
int a[MAX+5];
set<int> all;
map<int, int> mycount;
//std中有count
int main()
{
	int p; cin >> p;
	//用set计算知识点的个数n
	
	int n;
	for (int i = 0; i < p; i++) {
		//cin >> a[i];
		scanf("%d", &a[i]);
		all.insert(a[i]);
	}
	n = all.size();

	int left = 0, right = 0, num = 0;//num 记录这个区间包含的知识点数
	int result = p+1;
	//键是知识点,值是该知识点出现的次数
	for(;;)
	{
		while(right<p&&num<n)
		{
			if (mycount[a[right++]]++ == 0) {
				//count[a[right]]++; 知识点a[right] 只要出现 其count就应该++
				num++;
			}
		}
		if (num < n)break;
		result = min(result, right - left);
		//移动左端点
		if (--mycount[a[left++]] == 0)num--;//一个知识点没了
	}
	cout << result << endl;
	return 0;
}

更多推荐

E - Jessica‘s Reading Problem(尺取法)