题目传送门

题目描述

The Fool is numbered 0 the number of unlimited potential -and therefore does not have a specific place in the sequence of the Tarot cards . The Fool can be placed either at the beginning of the Marjor Arcam or at the end. The Major Arcana is often considered as the Fool's journey through life and as such, he is ever present and therefore needs no number.
Given n∈N+, print the parity of

where 

 

输入

The first line of the input contains one integer T≤100, denoting the number of testcases. Then T testcases follow.
In each of the T testcases, there is a positive number n≤109

输出

For each testcase, print a single line starting with “Case i:”( i indicates the case number) and then "even" or “odd’', separated with a single space.

样例输入

3
1
10000
100000000

样例输出

Case 1: odd
Case 2: even
Case 3: even

解题思路

列出前五十个数,就会发现一个规律,1-3为奇数,4-8为偶数,9-25为奇数....对n开方下取整然后判断奇偶即可

AC代码

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

int t,n;
int main()
{
    scanf("%d",&t);
    for(int k=1;k<=t;k++){
        scanf("%d",&n);
        int ans=sqrt(n);
        if(ans%2==1) printf("Case %d: odd\n",k);
        else printf("Case %d: even\n",k);
    }
    return 0;
}

 

更多推荐

THE FOOL 【找规律】