题目来源: UVA_10763
Foreign Exchange
Input: standard input
Output: standard output
Time Limit: 1 second

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task.

The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

input

The input file contains multiple cases. Each test case will consist of a line containing n - the number of candidates (1≤n≤500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate's original location and the candidate's target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.

 output

For each test case, print "YES" on a single line if there is a way for the exchange program to work out, otherwise print "NO".

 Sample Input
10
1 2
2 1
3 4
4 3
100 200
200 100
57 2
2 57
1 2
2 1
10
1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16

17 18
19 20
0
Sample Output
YES
NO

题意:第一行输入一个n,表示测试的案例,为0则结束,接下来的n组案例中输出n行,每行2个数,表示从A到B交换。

思路:定义int a[1000010],把所有的数输入到这个数组,用sort()函数进行排序,如果对于所有的相邻两个数相等,则符合,输出YES,else 输出NO。

代码:

#include<cstdio>
#include<algorithm>
int a[1000010];
using namespace std;
int main()
{
    int n,i;
   while(scanf("%d",&n)!=EOF&&n!=0)
  {
    for(int i=0;i<2*n;i++)
        scanf("%d",&a[i]);
        sort(a,a+2*n);
        for( i=0;i<2*n;i+=2)
        {
            if(a[i]!=a[i+1])
            break;

        }
        if(i>=2*n)
            printf("YES\n");
        else
            printf("NO\n");
  }
    return 0;
}






更多推荐

UVA_10763