Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task. The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!

Input

The input file contains multiple cases. Each test case will consist of a line containing n – the number of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s original location and the candidate’s target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.

Output

For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out, otherwise print ‘NO’.

Sample Input

10

1 2

2 1

3 4

4 3

100 200

200 100

57 2

2 57

1 2

2 1

10

1 2

3 4

5 6

7 8

9 10

11 12

13 14

15 16

17 18

19 20

0

Sample Output

YES

NO

题目:有n个学生想交换到其他学校学习。规定每个想从A学校到B学校的学生必须和一个从B学校去A学校的“配对”,如果每一个都可以找到(一个人不可以“配对”多人),学校就同意交换,输出'YES',否则输出'NO'。

思路:A→B和B→A的分别存入数组中,在分别排序,看是否相等即可。

代码如下:

#include<iostream>
#include<algorithm>
#include<string>
#include<queue>
using namespace std;
const int N = 500005;
int a[N],b[N];
int main(){
	int n,i;
	while(cin>>n && n){
		int mark=0;
		for(i=0;i<n;i++)
			scanf("%d %d",&a[i],&b[i]);
		sort(a,a+n);
		sort(b,b+n);
		for(i=0;i<n;i++)
		    if(a[i]!=b[i]){
		    	mark=1;
		    	break;
			}
		if(mark==0) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

 

更多推荐

UVA - 10763 Foreign Exchange