Description

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task. The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!
 

 

Input

The input file contains multiple cases. Each test case will consist of a line containing n { the number of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s original location and the candidate’s target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.
 

 

Output

For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out, otherwise print ‘NO’.
 

 

Sample Input

10
1 2
2 1
3 4
4 3
100 200
200 100
57 2
2 57
1 2
2 1
10
1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
0
 

 

Sample Output

YES
NO

 

 

解题思路:将学生的原学校与想去的学校以string的形式保存在map中,比如“1 2”,map中的value代表“1 2”出现的次数,即从1想去2的总人数。将全部学生的信息录入以后遍历map,将map中key值取反,例如“2 1”,再判断“2 1”是否在map中,若“2 1”与“1 2”在map中的key值相等,则可说明从1想去2的人数与从2想去1的人数相等

 

 

#include<iostream>  
#include<cstdio>  
#include<stack>  
#include<string>
#include<vector>
#include<sstream>
#include<math.h>
#include<map>
using namespace std;


int main() {
	
	int n;
	int a, b;
	int flag = 0;
	string student;
	string temp1;
	string temp2;
	map<string, int> m;

	while (scanf("%d",&n)!=EOF&&n!=0)
	{		
		flag = 0;
		for (int i = 0; i < n; i++)
		{
			scanf("%d%d", &a, &b);
			student = to_string(a) + " " + to_string(b);
			if (!m.count(student)) m[student] = 0;
			m[student]++;
		}
		
		for (map<string, int>::iterator it = m.begin(); it != m.end(); it++)
		{
			temp1 = it->first;
			stringstream ss;
			ss << temp1;
			ss >> a >> b;
			temp2 = to_string(b) + " " + to_string(a);
			if (m[temp1]!=m[temp2])
			{
				flag = 1;
				break;
			}
		}

		if (flag)
		{
			printf("NO\n");
		}
		else
		{
			printf("YES\n");
		}
		m.clear();
	}

	return 0;
}

 

更多推荐

UVA 10763 Foreign Exchange