Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input
5
1 8 8 8 1
Sample Output
2

题意:
求一个最小的区间覆盖所有种类的点

思路:
双指针

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <iostream>
#include <stack>
#include <vector>
#include <queue>
#include <map>

typedef long long ll;
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 1e6 + 7;

int a[maxn];
map<int,int>vis,vis2;

int main() {
    int n;scanf("%d",&n);
    int num = 0;
    for(int i = 1;i <= n;i++) {
        scanf("%d",&a[i]);
        if(!vis[a[i]]) {
            vis[a[i]] = 1;
            num++;
        }
    }
    int l = 1,now = 1;
    vis2[a[1]] = 1;
    int ans = INF;
    for(int i = 2;i <= n;i++) {
        if(!vis2[a[i]]) now++;
        vis2[a[i]]++;
        while(now == num) {
            ans = min(ans,i - l + 1);
            vis2[a[l]]--;
            if(!vis2[a[l]]) {
                now--;
            }
            l++;
        }
    }
    if(ans == INF) ans = 1;
    printf("%d\n",ans);
    return 0;
}

更多推荐

Jessica‘s Reading Problem POJ - 3320(双指针)